Feature Impaired

Incident Report for Encircle

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 05:25 EDT

Identified

We have identified an issue that may delay permissions updates within Encircle. This may impact your ability to see claims after they have been created. We are working to resolve this as quickly as possible, and apologize for the inconvenience.
Posted Jun 09, 2025 - 11:11 EDT
This incident affected: Encircle Platform.