Platform Impaired

Incident Report for Encircle

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 10:36 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 27, 2025 - 10:18 EDT

Identified

We have identified an issue that may cause performance issues or an inability to load Encircle on web or mobile. We are working to find the cause and resolve this as quickly as possible. We apologize for the inconvenience.
Posted Jun 27, 2025 - 10:12 EDT
This incident affected: Encircle Platform.