Application Impaired
Incident Report for Encircle
Resolved
We have found the issue and deployed a fix. Information on web and mobile apps should now automatically update as normal.
Posted Apr 16, 2024 - 14:26 EDT
Investigating
We have identified an issue that may cause outdated information to display in both the web and mobile app. This can be resolved by refreshing the claim or the page. iOS users may also experience app crashes. We are working to resolve this as quickly as possible.
Posted Apr 16, 2024 - 13:50 EDT
This incident affected: Encircle Mobile app and Encircle Web App.