Application Impaired

Incident Report for Encircle

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 17:01 EDT

Investigating

We've identified an issue that may cause slow syncing or the mobile app to display "stuck" even though the data is syncing slowly. We are working hard to fix this as soon as possible, and appreciate your patience as we work to resolve this.
Posted Mar 11, 2026 - 14:45 EDT
This incident affected: Encircle Mobile app.