Errors sending Link
Incident Report for Encircle
Resolved
A fix has been deployed and Link is working normally again.
Posted May 28, 2021 - 11:02 EDT
Identified
Users using the web and mobile platforms to send Encircle Link to policyholders will get stuck at the "Save & Send" step.

We've identified the problem and are working on deploying a fix (ETA 11am ET).
Posted May 28, 2021 - 09:56 EDT
This incident affected: Link by Encircle.