Feature Impaired

Incident Report for Encircle

Resolved

This incident has been resolved.
Posted Sep 22, 2023 - 12:50 EDT

Investigating

Users may be unable to create claims from an External Assignment on the mobile app. As a workaround, creating claims from External Assignments still works as intended on the web app.
Posted Sep 21, 2023 - 12:33 EDT
This incident affected: Encircle Mobile app.