Performance Degraded
Incident Report for Encircle
Resolved
This incident has been resolved.
Posted Jan 19, 2024 - 06:12 EST
Investigating
We have discovered an issue that is causing degraded performance with the platform in web browser and the mobile app. We are currently investigating the cause, and will work to resolve this as quickly as possible. We apologize for the inconvenience.
Posted Jan 18, 2024 - 14:44 EST
This incident affected: Encircle Platform.