Mobile Application Impaired
Incident Report for Encircle
Resolved
New app version released for IOS users
Posted May 23, 2023 - 11:33 EDT
Investigating
We have identified an issue affecting certain iOS devices running the latest iOS update 16.4.1. You might be unable to add a moisture point or window to a moisture map. Please refrain from updating to iOS 16.4.1 while we work on fixing the issue.
Posted May 18, 2023 - 11:49 EDT
This incident affected: Encircle Mobile app.