Platform Impaired

Incident Report for Encircle

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 18:06 EDT

Investigating

We have identified an issue that may cause performance issues or slow loading times on the mobile and desktop apps. We are working to find the cause and resolve this as quickly as possible. We apologize for the inconvenience.
Posted Jun 16, 2025 - 15:56 EDT
This incident affected: Encircle Platform.