General Performance Degradation
Incident Report for Encircle
Resolved
We have added additional capacity to our infrastructure and cleared the backlog.
Posted Nov 27, 2023 - 20:34 EST
Update
We are happy to report our database environment is fully online, and access to the Encircle environment is returning to normal. We have not encountered any data loss at this time, and no data loss has been reported by our customers. We will continue to monitor general performance and expect it to continue improving as the backlog of transactions clear out. Please expect us to be as transparent as possible going forward with a full explanation of what caused the incident once we have gone through a thorough analysis.
Posted Nov 27, 2023 - 13:13 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 27, 2023 - 12:57 EST
Identified
Update: We have taken web access down in order to relieve traffic on the servers as we redeploy the database fix. Mobile will work in offline mode if the user hasn't manually logged out previous to the incident. At this time we are expecting our database servers to be back online around 3pm EST, but we will provide further updates as they arise. Thank you for your patience.
Posted Nov 27, 2023 - 11:10 EST
Investigating
On Saturday evening Encircle scheduled a routine maintenance window to upgrade our database servers intended to increase overall performance of our platform. The maintenance has unfortunately resulted in issues that are temporarily causing significant degradation to our system. We currently have all hands on deck and hope to have more information on an estimated time to resolution soon. We apologize for this inconvenience.
Posted Nov 27, 2023 - 08:08 EST
This incident affected: Encircle Platform, Encircle Mobile app, Encircle Web App, Link by Encircle, and Encircle API.