A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2025 - 14:24 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 23, 2025 - 13:57 EST
Investigating
We have found an issue that may cause reports to take an extended amount of time to generate. Our team is working to resolve this as quickly as possible, and we appreciate your patience while we work on this issue.