Application Impaired
Incident Report for Encircle
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 12:01 EDT
Investigating
We have discovered an issue that may cause users to be unable to view photos, videos and notes on the web app. We are working to resolve this as quickly as possible and apologize for the inconvenience. As a temporary workaround, photos, videos, and notes on the mobile app.
Posted Apr 29, 2024 - 10:16 EDT
This incident affected: Encircle Web App.