Feature Impaired
Incident Report for Encircle
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 14:56 EDT
Identified
The web application inbox is currently slow to load and may fail to populate the list of files. We are working to resolve this as quickly as possible.
Posted Apr 08, 2024 - 10:34 EDT
This incident affected: Encircle Platform.