Platform impaired

Incident Report for Encircle

Resolved

Partner implemented a fix on their system. Incident is now resolved.
Posted Mar 25, 2025 - 15:08 EDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 25, 2025 - 14:22 EDT

Identified

One of our partners is currently experiencing an issue that is impacting access to Encircle. Our team is actively monitoring the situation and working with them to resolve the issue as quickly as possible. We will provide updates as soon as we have more information
Posted Mar 25, 2025 - 14:22 EDT
This incident affected: Encircle Mobile app and Encircle Web App.