High report latency

Incident Report for Encircle

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 22:44 EDT

Identified

We are currently investigating a high delay in reports processing. The backlog of reports should be normalized within the next hours
Posted Aug 14, 2025 - 22:10 EDT
This incident affected: Encircle Platform.