Performance Impaired
Incident Report for Encircle
Resolved
This incident has been resolved.
Posted Mar 29, 2023 - 10:57 EDT
Identified
We have noticed an issue affecting performance related to report generation. This may cause some reports to generate slowly or time out and not complete generating. We will ensure that any reports impacted by this issue will generate successfully once the issue is resolved. Please do not resubmit a report request that is already in progress. For status updates, go to https://status.encircleapp.com/
Posted Mar 29, 2023 - 10:26 EDT
This incident affected: Encircle Platform.