Feature Impaired

Incident Report for Encircle

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 20:32 EDT

Investigating

We have found an issue on mobile that may cause slowness when generating reports. This may also cause your mobile app to only show Encircle default reports in the list of documents to generate, without your custom forms. We are working to resolve this as quickly as possible, and apologize for the inconvenience.

As a temporary workaround, you may want to generate reports from the computer - once generated, forms can be signed on a mobile device.
Posted Apr 10, 2025 - 15:37 EDT
This incident affected: Encircle Mobile app.