Feature Impaired
Incident Report for Encircle
Resolved
This incident has been resolved.
Posted Sep 19, 2024 - 12:54 EDT
Investigating
We have identified an issue that may cause Encircle PDF reports to become stuck in processing if they include Hydro information. We are working to resolve this issue as quickly as possible, and apologize for the inconvenience.
Posted Sep 19, 2024 - 09:33 EDT
This incident affected: Encircle Platform.