Feature Impaired
Incident Report for Encircle
Resolved
This incident has been resolved.
Posted Jan 12, 2024 - 17:08 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 12, 2024 - 15:56 EST
Investigating
Creating claims on a web browser may get stuck when saving. As a workaround, create the claim on the mobile app or try removing the phone number. Enter the phone number once the claim is created.
Posted Jan 12, 2024 - 11:09 EST
This incident affected: Encircle Web App.