The issue has been identified and a fix is being implemented.
Posted Aug 09, 2024 - 10:43 EDT
Investigating
Users may find that when they share a claim with another user, they cannot see the other user's email listed under Shares. The shared user can still access the claim by searching their claim inbox. We are investigating this and looking to resolve it as quickly as possible.
Posted Aug 09, 2024 - 09:56 EDT
This incident affected: Encircle Mobile app and Encircle Web App.