Feature Impaired - Documents in Policyholder Link

Incident Report for Encircle

Resolved

This incident has been resolved.
Posted Sep 14, 2023 - 13:02 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 14, 2023 - 11:35 EDT

Identified

Policyholders may receive an error message when trying to open or sign documents sent to them using Policyholder link. We are working to find the cause and resolve this as quickly as possible
Posted Sep 14, 2023 - 11:35 EDT
This incident affected: Encircle Platform.