Apologies for the inconvenience. While we are working to bring the system back up, there is slowness in loading pages on the web and mobile app. We are working to resolve it as quickly as we can, and again apologize for the inconvenience.
Posted Aug 26, 2025 - 14:13 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2025 - 13:01 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 26, 2025 - 09:59 EDT
Identified
We have identified an issue that may cause pages to load slowly or fail to load on both web and the mobile app. We are working to resolve this issue as quickly as possible, and appreciate your patience.