Application Impaired
Incident Report for Encircle
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 13:18 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2024 - 10:59 EDT
Investigating
We have identified an issue that may cause the web and mobile application to load slowly. We are working to fix it as quickly as possible, and apologize for the inconvenience.
Posted Apr 15, 2024 - 10:04 EDT
This incident affected: Encircle Platform.