Platform impaired

Incident Report for Encircle

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 15:56 EST

Identified

We have confirmed that the issues logging in to Encircle are as a result of Network Connectivity issues with Microsoft Azure services in Canada. You should start seeing improvements, and we will update when the issue is resolved.
Posted Mar 03, 2025 - 14:48 EST

Investigating

We have identified an issue that may cause issues with logging in to Encircle on the web (desktop) and mobile app. Logging in may be delayed or may display an error message. Please try clearing your browser cache, or closing the app and logging in again as a workaround, while we work to resolve this issue. We apologize for the inconvenience.
Posted Mar 03, 2025 - 11:50 EST
This incident affected: Encircle Platform.